[Resolved] Incorrect data displayed on the network dashboard

Started on October 10, 2021 at 11:51 AM. Resolved after about 21 hours

Affected

Network Dashboard
  • Investigating
    October 10, 2021 at 11:51 AM

    The network dashboard displays incorrect data, including some duplicate bakers.

    The network is operating normally apart from the display issue.

  • Resolved
    October 11, 2021 at 8:41 AM

    We just resolved the issue!