Identity creation with Notabene is temporarily disabled in all Concordium wallets.

Resolved
Operational
Started 12 months ago Lasted 2 months

Affected

Identity Providers
Updates
  • Resolved
    Resolved

    This incident has been resolved. Identity creation with Notabene works in all Concordium wallets again.

  • Investigating
    Investigating

    Identity creation with Notabene is temporarily disabled in all Concordium wallets. Please use our other identity provider DTS to create new identities.

    Existing identities issued by Notabene are still valid and identity and account recovery works for both Notabene and DTS identities. Only creation of new Notabene identities is affected.