Resolved
Identity provider DTS currently unreachable

Started
November 23, 2022 at 2:15 PM
Status
Resolved after about 1 hour

Impact

Partial outage
Affected
Identity Providers
  • Resolved
    Resolved

    The identity provider DTS is operational again.

  • Investigating
    Investigating

    Our identity provider DTS is currently unreachable. We have informed them and they are investigating the incident.

    To create new identities, please use Notabene instead.